Main Stories
Slash Boxes

Slash Open Source Project

Slashcode Log In

Log In

[ Create a new account ]

Article Poll

Poll I found this article to be
Very Helpful
Helpful
Not Helpful
Not Very Helpful
[ Results | Polls ]
Comments:0 | Votes:0

Problem starting apache with the slash httpd.conf

posted by CaptTofu on 10:12 AM January 2nd, 2001   Printer-friendly   Email story

meteau writes "I'm trying to start apache with slash installed. I'm pretty sure I followed the installation correctly but am having a problem. If I start apache with the default httpd.conf, it starts and works fine, but if I use the one from the slash tarball, I get the following error:

Syntax error on line 364 of /usr/local/apache/conf/httpd.conf Invalid command '<Perl>', perhaps mis-spelled or defined by a module not included in the server configuration.

The error is pointing to this section:

<Perl> package Slash::Host::slashcode;

etc
etc
etc

</Perl>

any ideas as to which module may not be installed properly or where this may be coming from? Thanks"
This discussion has been archived. No new comments can be posted.
The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login
Loading... please wait.
  • looks like you've not installed mod_perl correctly. just do the following from your shell to try:
    telnet localhost 80 <enter>
    GET / HTML/1.0 <enter><enter>
    and check the "Server:" string which comes back from your httpd.
    There should be something like "mod_perl/1.24_01", otherwise that's the problem :-)
  • oh, how right you were....thx
  • Not sure were to post this. Completed the install of Fry but apache will not start now. It doesn't throw an error it just doesn't start. If I remove comment the following out of the /usr/local/slash/httpd/slash.conf apache will start, but slash doesn't work. #PerlModule Slash #PerlModule Slash::Apache #PerlModule Slash::Apache::User Any ideas???