Main Stories
Slash Boxes

Slash Open Source Project

Slashcode Log In

Log In

[ Create a new account ]

Article Poll

Poll I found this article to be
Very Helpful
Not Helpful
Not Very Helpful
[ Results | Polls ]
Comments:0 | Votes:0

Upgrading Apache to 1.3.19

posted by Krow on 08:00 AM March 16th, 2001   Printer-friendly   Email story
Anonymous Coward writes "hi, I run apache 1.3.11 and slash and have been having trouble installing apache 1.3.19. I recompiled it with mod perl 1.25 but it tells me that my is an old version and the server just dies. Is there anything I need to know when I upgrade apache running slash? thanks."
This discussion has been archived. No new comments can be posted.
The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
More | Login
Loading... please wait.
  • I ran into this too. You need to

    1. make sure you recompile fresh apache & mod_perl.
    2. then you need to use cpan or go download
    the lastest perl apache modules, make UNINST=1
    when you install it.

    Then you should be OK. I put my apache instructions up online at

    I worked with everyone on the slash irc
    channel to get that going. The ultimate goal of it was to have the latest apache, mod_perl, ssl and php4 in a working system.

    It's getting there. Checkout the
    lottadot []
  • I get a similar error, but everything works fine for me. Here is what is reported in my apache log file:

    [Thu Mar 15 03:47:05 2001] [notice] caught SIGTERM, shutting down version 1.26 required! /usr/lib/perl5/site_perl/5.6.0/i386-linux/Apache.p m is version 1.27 Perhaps you forgot to 'make install' or need to uninstall an old version? Found: /usr/lib/perl5/site_perl/5.6.0/i386-linux/Apache.p m [Thu Mar 15 03:48:45 2001] [notice] Apache/1.3.14 (Unix) (Red-Hat/Linux) mod_ssl/2.7.1 OpenSSL/0.9.