Main Stories
Slash Boxes

Slash Open Source Project

Slashcode Log In

Log In

[ Create a new account ]

Article Poll

Poll I found this article to be
Very Helpful
Helpful
Not Helpful
Not Very Helpful
[ Results | Polls ]
Comments:0 | Votes:0

Perl 5.8.0 and Slash

posted by Krow on 12:53 PM July 21st, 2002   Printer-friendly   Email story
I tried this morning to get perl 5.8.0 to work with Slash and ran into a bunch of errors. Mainly in Apache and Mod_perl. Anyone have any pointers to follow to install it?
This discussion has been archived. No new comments can be posted.
The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login
Loading... please wait.
  • I just installed a fresh slash site and had some errors during the Bundle::Slash install. This was before Perl 5.8.0. I then took a break from it, came back a day later and ran Bundle::Slash again and it tried to install 5.8.0. I stopped it, but was afraid it's going to wreck everything I've done from this point on. Is there anyway to reload old Bundle::Slash and Bundle::CPAN?
    • well, i too had lots of problems. My journal [slashcode.com] documents it.

      Its not that hard to do actually. Some of the modules, like Template Toolkit, failed on tests. I also found that if I installed Perl 5.8 first then compiled Mod_perl and Apache, then went and did the CPAN bundles and the Slash Bundles, it went a little smoother.

      Something that used to not work right at all, the DBI Mysql stuff, that went fine. Surprisingly fine. But GD 1.40 and Template Toolkit were the pains for me. I actually ended up installing without a make test. Everything seems to be working so far.....

      --

      --
      It's either on the beat or off the beat, it's that easy.
  • This may be stating the obvious, but Perl 5.8.0 is not necessarily binary compatible with the Perl you previously had.
    Odd are that it isn't.

    So you need to recompile your mod_perl and any other modules.
    --
    ---ict.
  • So if I wanted to start out with a new slash site, and install CPAN, and Bundle::Slash, how would I get CPAN to not install Perl 5.8? I've tried this, but it wants to install 5.8 every time? Any insight?
  • There is a thread on PerlMonks that starts with How to prevent CPAN from updating Perl [perlmonks.org]. I have not followed the instructions myself, but Randal Schwartz recommended updating CPAN.pm in order to avoid the update to Perl 5.6.1. Seems like a reasonable bet to work for Perl 5.8.0.
    --

    --

    Dave Aiello
    Chatham Township Data Corporation [ctdata.com]

  • I just noticed that I'm getting an error in comments.pl.
    [Mon Jul 22 19:42:27 2002] [error] Invalid [] range "]-+" in transliteration operator at /usr/local/slash/site//www.jazz-sax.com/htdocs/com ments.pl line 829.

    I'm using Perl 5.8.0

    --

    --
    It's either on the beat or off the beat, it's that easy.